PCPartPicker

  • Log In
  • Register

Don't have full administrator rights on my own PC. (Windows 10)

Forum Search

Guidelines

  • Be respectful to others
  • No spam
  • No NSFW content
  • No piracy or key resellers
  • No link shorteners
  • Offensive content will be removed

Topic

GunsmokeTX 28 months ago

So after I did my clean install of Windows 10, I installed on a different drive, and I want to delete my old OS that's still on the other drive. But it says I need permission from the owner. I AM THE OWNER. This is beyond frustrating. I can't find anything about this on the internet either. Why don't I have full control of my PC? How can I get full control so I can delete the files?

Comments Sorted by:

SCDAS141 1 point 28 months ago

Enable the Administrator Account on win 10 which is disabled by default. Windows icon -> type cmd -> net user administrator /active:yes

Full detailed procedure: http://www.ghacks.net/2014/11/12/how-to-enable-the-hidden-windows-10-administrator-account/

GunsmokeTX submitter 1 point 28 months ago

This didn't work. I'm not sure what else to do. Every time I try to delete it, it says I need permission from <owner name here>. I can change who the owner is, but I'm not sure which admin account is mine.

SCDAS141 1 point 28 months ago

Why don't u download The "Paragon Rescue Kit 14 Free" and burn it to a CD/USB.. Booting from it & Wiping it clean will restore the HDD..

http://www.paragon-software.com/home/rk-free/download.html

ACRONIS DISK DIRECTOR is another software suite you could use but it isn't free!!

GunsmokeTX submitter 1 point 28 months ago

What?? I don't wanna wipe what's on my drive. I'm just trying to delete a couple of folders.

I'm completely lost, and Microsoft has made this way more complicated than it needs to be. How am I supposed to know that I'm even using the right account? Obviously I'm not or I'd be able to delete folders on my own computer.

SCDAS141 1 point 28 months ago

You can do anything dude.. just download it & burn it to a cd, boot from the cd by chooosing "Boot from cd" option in the BIOS.. u can copy/cut/paste/delete whatever u want from any Hard-disk to any Hard-disk

Hope this helps!!

GunsmokeTX submitter 1 point 28 months ago

This might be a temporary solution, but I would still like full control of my own PC. This frustrating on a whole other level. I give myself ownership of the particular file(s) I'm trying to delete, and it still says I need permission. This makes no sense.

Pcjulian12343 1 point 17 months ago

I get how you feel, windows doesnt let you delete certain files for a reason becuase they can break the OS

FH100 1 point 28 months ago

Only thing I can think of, and seems like something that might happen (considering this rollout), is that the user account you're using doesn't have administrative privileges. Solution would be to give yourself Admin rights, most likely somewhere in Control Panel > User Accounts > Change Account Type. Don't have 10, so can't make sure.

GunsmokeTX submitter 1 point 28 months ago

Every time I try to give myself Administrator rights, it automatically reverts back to "Standard", not allowing me to have full control. Why??

Even when I give myself ownership of a file I'm trying to delete, it still says I need permission from the owner....

FH100 1 point 28 months ago

I'm guessing the answer to "Why?" is some sort of misguided attempt at safety. Fine for those who never need Admin privileges, but a pain to those who do... Sorry I can't help more.

[comment deleted]
LemonComputers 1 point 16 months ago

12 months ago

[comment deleted]
Stuart_Munto 3 Builds 1 point 28 months ago

Oh man, I've seen this before. You may need to right click on the folder you want to delete, and go into the security menu and see if you have access to read/write for that folder. I think Windows 10 doesn't know who the owner is as it is from a previous install, so it has locked you out. But I'm pretty sure you can allow yourself access by changing the security settings for that folder. I'm not sure of the actual process but this sounds like it may work

GunsmokeTX submitter 1 point 28 months ago

I've tried this, but honestly I'm not sure how to tell which one is mine. I've given full control to everyone one of them, but it still tells me I need permission from the owner.

Stuart_Munto 3 Builds 1 point 28 months ago

Hmmm, there's gotta be a way. Have you tried googling it. Normally a Microsoft help site should come up and they are actually very helpful (surprise!) I'm sure its gotta be a security permission setting for that folder though. You should be able to give permission to any administrator to read/write any folder, which will then give you the ability to delete.... Easier said than done I know!

Porkyville 0 points 28 months ago

Dont worry dude its the same on mine a fix will come in time those files aint going anywere just enjoy the speed and usability.

GeekWon 1 point 28 months ago

Its unclear how you installed win 10, upgraded, dual boot, or clean install.

Boot Windows into the PreBoot environment start->PC settings->update and recovery then select advanced startup. This will boot the PC in the windows pre-boot environment. Open a command prompt, navigate to the dirve/folder you want and delete it. At this point you have full control of the contents of the drivers, but be careful what you do.

GunsmokeTX submitter 1 point 28 months ago

I appreciate the response, but you're a bit late. I'm still not sure if I have full administrator rights, but I messed it up even further, and out of desperation, I did another clean install (Yes, the first time was also a clean install). And I re-formatted the drive that had the contents that I was wanting to delete, and just wiped it completely. So all is good now.

grizzlyman 2 Builds 1 point 28 months ago

I know I'm late as well, but I was having issues deleting the old OS files on my drive after I upgraded to win 10. I had to use disk cleanup to get rid of that stuff.

GunsmokeTX submitter 1 point 28 months ago

Well, I was having issues with that, and the previous OS entirely. I had "Windows.old" and just "Windows" taking up massive amounts of space on my SSD, and I couldn't delete either of them because apparently, it wasn't mine to delete, according to my PC, even though I'm the only owner of this PC.

grizzlyman 2 Builds 1 point 28 months ago

Right on, I was in the same boat. I just mentioned it in case anyone else runs into the same problem. Using Windows disk cleanup allowed me to delete the windows.old file. Glad you got it sorted.

GunsmokeTX submitter 1 point 28 months ago

Not sure if it's only a temporary solution to force it to wipe the drive, and be reformatted, but it's a solution, nonetheless.

ahmedhara 1 point 17 months ago

If you have an external hard dive you could pherhaps save all the files you need on it and reinstall the operating system

LemonComputers 1 point 17 months ago

Try this: http://www.pcworld.com/article/2988539/windows/if-you-forget-your-windows-admin-password-try-this.html

You may need to contact Microsoft Support or copy all of your files onto an external hard drive and reformat Windows. If Microsoft Support can't help and booting the Kaspersky TDSSKiller off a disc can't help, you're pretty much out of luck...

pacificapilot 1 point 16 months ago

I just had this same problem. This is what I did:

Go to "This PC"

Right click on the drive you want to access

Select "Properties"

Click on the "Security" tab

Click "Advanced." This will open a new window

At the top, where it lists the current owner, click "Change." A dialog box will appear

In the text field labeled "Enter the object name to select," type in your username. So if my username on that account I am currently on was named "John," than I would simply type "John" into the text field.

Now click on "Check Names"

Click OK

On the bottom of the current dialog box, there is a check box with the text "Replace all child object permission entries with inheritable entries from this object." This needs to be checked.

Click OK

Click OK again

Hope this helps!
jamkor 1 point 16 months ago

After sorting through 10s of these threads, and since this one comes up very high in the search results - i wanted to say that this: http://www.tenforums.com/tutorials/3841-take-ownership-add-context-menu-windows-10-a.html was the only thing that worked.

[comment deleted]
[comment deleted by staff]
philip staff 10 Builds 1 point 16 months ago

Look, I'm all for helpful advice, but lose the insults and condescension.