add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Comments

Comments

Comment reply on jamantste's Completed Build: Black and White - First Build

  • 3 months ago
  • 1 point

Very clean and nicely color coordinated. Well done!

Comment reply on Zezainster's Completed Build: RGB Master

  • 13 months ago
  • 1 point

Those back plates look amazing! How did you color them white? Paint? I just got the same card and I'm looking to get rid of the yellow stripe like you did.

Comment reply on mpnx900's Completed Build: Black Friday Build

  • 49 months ago
  • 1 point

Awesome mod to the case! Got a question about the PSU, is there noticeable fan noise at all? I recently built one with an EVGA NEX750G and you could definitely hear the fan just at idle. Was this the case with the NEX 650G?

Comment reply on rjyapp's Completed Build: New Work Station / Enthoo Evolv ATX

  • 52 months ago
  • 1 point

Looks mean and clean, excellent work!

Comment reply on A1337Haxor's Completed Build: twentyfifteen

  • 53 months ago
  • 1 point

Clean!

Comment reply on Forum Topic "ASUS Z97-A Inaccessible BIOS / Boot Device LED"

  • 53 months ago
  • 1 point

Hopefully! I will try and contact them.

Comment reply on Forum Topic "ASUS Z97-A Inaccessible BIOS / Boot Device LED"

  • 53 months ago
  • 1 point

Ohh gotcha, yeah definitely not normal. I guess I'll have to do some more research on what could have caused that and if its causing the problem..

Comment reply on Forum Topic "ASUS Z97-A Inaccessible BIOS / Boot Device LED"

  • 53 months ago
  • 1 point

Is that the ASUS Z97-A? Whats wrong with it? Just a picture of the back of a motherboard...

Comment reply on Forum Topic "ASUS Z97-A Inaccessible BIOS / Boot Device LED"

  • 53 months ago
  • 1 point

Yes, I did remove the cooler from the CPU, cleaned, and re-applied thermal paste. The only change was the position of the radiator. And i have tried booting with out the drives connected, and still same issue.

I've also discovered this at the back of the motherboard, looks small but definitely doesn't look good. http://linustechtips.com/main/gallery/image/21808-what-is-this/

Not sure what is is, I am concerned it's causing the issue...

Comment reply on only1battman's Completed Build: Video Editing, CAD, and a wee bit of gaming Monster

  • 53 months ago
  • 1 point

Awesome build! Really clean.

I have the Define R4 and h100i , and I'm considering re-positioning the h100i to the front like you did. My only concern is the clearance of the front panel connectors being right behind the re-positioned hard drive bay next to the PSU. Obviously you've done it here, was it a tight fit?

Comment reply on oldgregggggg's Completed Build: 0 to 100 Real Quick

  • 54 months ago
  • 1 point

So clean. White back-plates!!!! Awesome. Started from the bottom now ya here!

^ sorry had to say it lmao

Comment reply on lha_luke's Completed Build: DEFINE - The Gaming & Workstation PC

  • 54 months ago
  • 2 points

I agree. Thanks!

Comment reply on lha_luke's Completed Build: DEFINE - The Gaming & Workstation PC

  • 54 months ago
  • 2 points

There are two 140mm fans behind the sound dampening front panel, with the intake vents on the side. Any review of the case on YouTube should show it with greater detail!

Comment reply on lha_luke's Completed Build: DEFINE - The Gaming & Workstation PC

  • 54 months ago
  • 1 point

At the time it was the only option for a reference GTX 980 SC, it was out of stock everywhere at launch 7 months ago. And I have considered going with an EVGA psu. Perhaps next time!

Comment reply on lha_luke's Completed Build: DEFINE - The Gaming & Workstation PC

  • 54 months ago
  • 1 point

I will admit, I am a fan of Corsair, there are better brands. However I've had the system for 7 months with no issues! When I do upgrade in the future I will probably go with other brands.

Comment reply on EchoLenix's Completed Build: First Build

  • 54 months ago
  • 1 point

So clean! Awesome stuff.

Comment reply on LuckYstrYke's Completed Build: THe JUDGE !!!

  • 58 months ago
  • 2 points

Nice! Awesome Pictures.

Comment reply on skemble's Completed Build: Ysera's Demise

  • 61 months ago
  • 1 point

Oh nice! I'm gonna get some for sure, god bless NZXT for making those!

Comment reply on skemble's Completed Build: Ysera's Demise

  • 61 months ago
  • 1 point

Those braided cables everywhere look so good! I'm guessing they don't come with the CX600M?

Comment reply on skemble's Completed Build: Ysera's Demise

  • 61 months ago
  • 1 point

Awesome pictures and build.

Comment reply on Forum Topic "First PC Build Plan. Feedback?"

  • 63 months ago
  • 1 point

Oh perfect!

And hmm okay, whats your opinion on the corsair cs650m? Gold rated, I dont know anything about the manufacturer though.

Comment reply on Forum Topic "First PC Build Plan. Feedback?"

  • 63 months ago
  • 1 point

Thanks for the feedback! I'll look into a western digital hardrive, and a few more fans because I'm quite fond of the stock cooler for the 780. As for the PSU, do you have a specific recommendation? My only preference is a corsair PSU compatible withe the corsair cpu cooler software.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube